Erro Instalação Angular 2

angular

#1

Comprei o Livro “Crie aplicações com Angular” e no momento de levantar o servidor estes erros estão sendo exibidos:

pm WARN deprecated angular-cli@1.0.0-beta.28.3: angular-cli has been renamed to @angular/cli. Please update your dependencies.
npm WARN deprecated gulp-util@3.0.7: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! code ENOVERSIONS
npm ERR! No valid versions available for timed-out

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\ADM\AppData\Roaming\npm-cache_logs\2018-01-06T19_52_50_061Z-debug.log


#2

Olá Fabio, tudo bem?

Seu angular-cli está desatualizado, você vai precisar trocar a versão do angular-cli@1.0.0-beta.28.3 para o novo angular-cli que está na versão 1.6.3, essa nova versão é compatível com o Angular 5.

Segue link do repositório do angular-cli:

Basicamente você terá que fazer uninstall da sua versão e depois o install no novo angular-cli.

Qualquer dúvida ou problemas estamos a disposição.

Att

Thiago guedes


#3

Ontem deu um erro no servidor do NPM. Parou todo mundo! Tentei fechar o tópico mas não consegui!

require-from-string dependency error #103

#npmblackhole
https://twitter.com/hashtag/npmblackhole?src=hash

Obrigado por ter sido solicito!