# Erro o rodar aplicação Java EE

**URL:** <https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465>\
**Category:** Livros\
**Tags:** java-ee\
**Created:** [Março 15, 2017, 1:34am UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465 "2017-03-15T01:34:08Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![danilogp](https://avatars.discourse-cdn.com/v4/letter/d/f17d59/32.png) [@danilogp](https://forum.casadocodigo.com.br/u/danilogp)\
**Post date:** [Março 15, 2017, 1:34am UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/1 "2017-03-15T01:34:08Z")

</div>

Ao executar o projeto não esta mostrando a pagina form.xhtm esta mostra o erro 404 not foundl. Esta retornando o erro do servidor wildfly:

```
Caused by: javax.persistence.PersistenceException: JBAS011466: PersistenceProvider '
org.hibernate.ejb.HibernatePersistence ' not found

```

Estou no final do capitulo 3 do livro Java EE.

alguem poderia me informar onde esta o erro?

---

<div class="post-metadata">

**Author:** ![gracyane\_oliveira](https://avatars.discourse-cdn.com/v4/letter/g/f9ae1b/32.png) [@gracyane\_oliveira](https://forum.casadocodigo.com.br/u/gracyane_oliveira)\
**Post date:** [Março 15, 2017, 2:01am UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/2 "2017-03-15T02:01:09Z")

</div>

Você criou o banco? Verifique o nome do banco se está correto.

---

<div class="post-metadata">

**Author:** ![danilogp](https://avatars.discourse-cdn.com/v4/letter/d/f17d59/32.png) [@danilogp](https://forum.casadocodigo.com.br/u/danilogp)\
**Post date:** [Março 15, 2017, 4:23pm UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/3 "2017-03-15T16:23:24Z")

</div>

Criei com o nome de casadocodigo e a tabela book com os mesmos nomes da classe, mesmo assim esta ocorrendo o erro.

```
13:15:13,036 INFO [org.jboss.modules] (main) JBoss Modules version 1.3.3.Final
13:15:15,158 INFO [org.jboss.msc] (main) JBoss MSC version 1.2.2.Final
13:15:15,370 INFO [org.jboss.as] (MSC service thread 1-7) JBAS015899: WildFly 8.2.1.Final "Tweek" starting
13:15:26,211 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015003: Found casadocodigo.war in deployment directory. To trigger deployment create a file called casadocodigo.war.dodeploy
13:15:26,257 INFO [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http)
13:15:26,446 INFO [org.xnio] (MSC service thread 1-5) XNIO version 3.3.0.Final
13:15:26,595 INFO [org.xnio.nio] (MSC service thread 1-5) XNIO NIO Implementation Version 3.3.0.Final
13:15:26,818 WARN [org.jboss.as.txn] (ServerService Thread Pool -- 52) JBAS010153: Node identifier property is set to the default value. Please make sure it is unique.
13:15:26,827 INFO [org.jboss.as.security] (ServerService Thread Pool -- 51) JBAS013171: Activating Security Subsystem
13:15:26,838 INFO [org.jboss.as.clustering.infinispan] (ServerService Thread Pool -- 35) JBAS010280: Activating Infinispan subsystem.
13:15:26,842 INFO [org.jboss.as.naming] (ServerService Thread Pool -- 46) JBAS011800: Activating Naming Subsystem
13:15:26,848 INFO [org.jboss.as.jacorb] (ServerService Thread Pool -- 36) JBAS016300: Activating JacORB Subsystem
13:15:26,862 INFO [org.jboss.as.jsf] (ServerService Thread Pool -- 42) JBAS012615: Activated the following JSF Implementations: [main]
13:15:27,007 INFO [org.jboss.as.connector.logging] (MSC service thread 1-3) JBAS010408: Starting JCA Subsystem (IronJacamar 1.1.9.Final)
13:15:27,034 INFO [org.jboss.as.webservices] (ServerService Thread Pool -- 54) JBAS015537: Activating WebServices Extension
13:15:27,288 INFO [org.wildfly.extension.io] (ServerService Thread Pool -- 34) WFLYIO001: Worker 'default' has auto-configured to 8 core threads with 64 task threads based on your 4 available processors
13:15:27,848 INFO [org.wildfly.extension.undertow] (MSC service thread 1-2) JBAS017502: Undertow 1.1.8.Final starting
13:15:27,849 INFO [org.wildfly.extension.undertow] (ServerService Thread Pool -- 53) JBAS017502: Undertow 1.1.8.Final starting
13:15:28,701 INFO [org.jboss.as.security] (MSC service thread 1-4) JBAS013170: Current PicketBox version=4.0.21.Final
13:15:28,844 INFO [org.wildfly.extension.undertow] (ServerService Thread Pool -- 53) JBAS017527: Creating file handler for path C:\Users\danil\wildfly-8.2.1.Final/welcome-content
13:15:29,313 INFO [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 30) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3)
13:15:29,322 INFO [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-1) JBAS010417: Started Driver service with driver-name = h2
13:15:29,728 INFO [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 30) JBAS010404: Deploying non-JDBC-compliant driver class com.mysql.jdbc.Driver (version 5.1)
13:15:29,730 INFO [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-6) JBAS010417: Started Driver service with driver-name = mysql
13:15:30,446 INFO [org.jboss.as.naming] (MSC service thread 1-4) JBAS011802: Starting Naming Service
13:15:30,450 INFO [org.jboss.as.mail.extension] (MSC service thread 1-2) JBAS015400: Bound mail session [java:jboss/mail/Default]
13:15:31,585 WARN [jacorb.codeset] (MSC service thread 1-7) Warning - unknown codeset (Cp1252) - defaulting to ISO-8859-1
13:15:31,902 INFO [org.jboss.as.server.deployment] (MSC service thread 1-3) JBAS015876: Starting deployment of "casadocodigo.war" (runtime-name: "casadocodigo.war")
13:15:31,906 INFO [org.jboss.as.server.deployment.scanner] (MSC service thread 1-1) JBAS015012: Started FileSystemDeploymentService for directory C:\Users\danil\wildfly-8.2.1.Final\standalone\deployments
13:15:32,584 INFO [org.jboss.as.jacorb] (MSC service thread 1-7) JBAS016330: CORBA ORB Service started
13:15:33,416 INFO [org.wildfly.extension.undertow] (MSC service thread 1-6) JBAS017525: Started server default-server.
13:15:33,472 INFO [org.wildfly.extension.undertow] (MSC service thread 1-6) JBAS017531: Host default-host starting
13:15:33,589 INFO [org.wildfly.extension.undertow] (MSC service thread 1-6) JBAS017519: Undertow HTTP listener default listening on localhost/127.0.0.1:8080
13:15:33,601 INFO [org.jboss.remoting] (MSC service thread 1-8) JBoss Remoting version 4.0.7.Final
13:15:33,619 INFO [org.jboss.as.jacorb] (MSC service thread 1-4) JBAS016328: CORBA Naming Service started
13:15:33,863 WARN [org.jboss.as.messaging] (MSC service thread 1-1) JBAS011600: AIO wasn't located on this platform, it will fall back to using pure Java NIO. If your platform is Linux, install LibAIO to enable the AIO journal
13:15:34,008 INFO [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-4) JBAS010400: Bound data source [java:jboss/datasources/ExampleDS]
13:15:34,008 INFO [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-4) JBAS010400: Bound data source [java:jboss/datasources/casadocodigoDS]
13:15:34,593 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221000: live server is starting with configuration HornetQ Configuration (clustered=false,backup=false,sharedStore=true,journalDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messagingjournal,bindingsDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messagingbindings,largeMessagesDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messaginglargemessages,pagingDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messagingpaging)
13:15:34,622 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221006: Waiting to obtain live lock
13:15:34,907 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221013: Using NIO Journal
13:15:35,447 INFO [io.netty.util.internal.PlatformDependent] (ServerService Thread Pool -- 56) Your platform does not provide complete low-level API for accessing direct buffers reliably. Unless explicitly requested, heap buffer will always be preferred to avoid potential system unstability.
13:15:35,681 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221043: Adding protocol support CORE
13:15:35,970 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221043: Adding protocol support AMQP
13:15:35,974 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221043: Adding protocol support STOMP
13:15:36,219 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221034: Waiting to obtain live lock
13:15:36,219 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221035: Live Server Obtained live lock
13:15:37,538 INFO [org.jboss.as.jpa] (MSC service thread 1-3) JBAS011401: Read persistence.xml for casadocodigo-dev
13:15:37,620 INFO [org.jboss.messaging] (MSC service thread 1-2) JBAS011615: Registered HTTP upgrade for hornetq-remoting protocol handled by http-acceptor-throughput acceptor
13:15:37,620 INFO [org.jboss.messaging] (MSC service thread 1-7) JBAS011615: Registered HTTP upgrade for hornetq-remoting protocol handled by http-acceptor acceptor
13:15:38,272 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221007: Server is now live
13:15:38,272 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221001: HornetQ Server version 2.4.5.FINAL (Wild Hornet, 124) [54408336-f7c9-11e6-abc8-3d133fa96cc9] 
13:15:38,281 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221003: trying to deploy queue jms.queue.ExpiryQueue
13:15:38,289 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 56) JBAS011601: Bound messaging object to jndi name java:/jms/queue/ExpiryQueue
13:15:38,261 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC000001: Failed to start service jboss.deployment.unit."casadocodigo.war".FIRST_MODULE_USE: org.jboss.msc.service.StartException in service jboss.deployment.unit."casadocodigo.war".FIRST_MODULE_USE: JBAS018733: Failed to process phase FIRST_MODULE_USE of deployment "casadocodigo.war"
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:166) [wildfly-server-8.2.1.Final.jar:8.2.1.Final]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1948) [jboss-msc-1.2.2.Final.jar:1.2.2.Final]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1881) [jboss-msc-1.2.2.Final.jar:1.2.2.Final]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_112]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_112]
	at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_112]
Caused by: javax.persistence.PersistenceException: JBAS011466: PersistenceProvider '
		org.hibernate.ejb.HibernatePersistence
	' not found
	at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.lookupProvider(PersistenceUnitServiceHandler.java:990)
	at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.addPuService(PersistenceUnitServiceHandler.java:258)
	at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.handleWarDeployment(PersistenceUnitServiceHandler.java:191)
	at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.deploy(PersistenceUnitServiceHandler.java:126)
	at org.jboss.as.jpa.processor.PersistenceBeginInstallProcessor.deploy(PersistenceBeginInstallProcessor.java:52)
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:159) [wildfly-server-8.2.1.Final.jar:8.2.1.Final]
	... 5 more

13:15:38,405 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 59) JBAS011601: Bound messaging object to jndi name java:jboss/exported/jms/RemoteConnectionFactory
13:15:38,407 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 58) JBAS011601: Bound messaging object to jndi name java:/ConnectionFactory
13:15:38,407 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 57) HQ221003: trying to deploy queue jms.queue.DLQ
13:15:38,409 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 57) JBAS011601: Bound messaging object to jndi name java:/jms/queue/DLQ
13:15:38,717 INFO [org.jboss.as.connector.deployment] (MSC service thread 1-3) JBAS010406: Registered connection factory java:/JmsXA
13:15:38,932 INFO [org.hornetq.ra] (MSC service thread 1-3) HornetQ resource adaptor started
13:15:38,936 INFO [org.jboss.as.connector.services.resourceadapters.ResourceAdapterActivatorService$ResourceAdapterActivator] (MSC service thread 1-3) IJ020002: Deployed: file://RaActivatorhornetq-ra
13:15:38,941 INFO [org.jboss.as.connector.deployment] (MSC service thread 1-3) JBAS010401: Bound JCA ConnectionFactory [java:/JmsXA]
13:15:38,942 INFO [org.jboss.as.messaging] (MSC service thread 1-3) JBAS011601: Bound messaging object to jndi name java:jboss/DefaultJMSConnectionFactory
13:15:39,889 INFO [org.jboss.ws.common.management] (MSC service thread 1-6) JBWS022052: Starting JBoss Web Services - Stack CXF Server 4.3.2.Final
13:15:39,896 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) JBAS014613: Operation ("deploy") failed - address: ([("deployment" => "casadocodigo.war")]) - failure description: {"JBAS014671: Failed services" => {"jboss.deployment.unit.\"casadocodigo.war\".FIRST_MODULE_USE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"casadocodigo.war\".FIRST_MODULE_USE: JBAS018733: Failed to process phase FIRST_MODULE_USE of deployment \"casadocodigo.war\"
    Caused by: javax.persistence.PersistenceException: JBAS011466: PersistenceProvider '
		org.hibernate.ejb.HibernatePersistence
	' not found"}}
13:15:40,013 INFO [org.jboss.as.server] (ServerService Thread Pool -- 31) JBAS018559: Deployed "casadocodigo.war" (runtime-name : "casadocodigo.war")
13:15:40,024 INFO [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014777: Services which failed to start: service jboss.deployment.unit."casadocodigo.war".FIRST_MODULE_USE: org.jboss.msc.service.StartException in service jboss.deployment.unit."casadocodigo.war".FIRST_MODULE_USE: JBAS018733: Failed to process phase FIRST_MODULE_USE of deployment "casadocodigo.war"

13:15:40,225 INFO [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management
13:15:40,226 INFO [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
13:15:40,227 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: WildFly 8.2.1.Final "Tweek" started (with errors) in 29848ms - Started 236 of 286 services (1 services failed or missing dependencies, 95 services are lazy, passive or on-demand)
13:15:40,304 INFO [org.jboss.as.server.deployment] (MSC service thread 1-3) JBAS015877: Stopped deployment casadocodigo.war (runtime-name: casadocodigo.war) in 40ms
13:15:40,496 INFO [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018558: Undeployed "casadocodigo.war" (runtime-name: "casadocodigo.war")
13:15:40,497 INFO [org.jboss.as.controller] (DeploymentScanner-threads - 2) JBAS014774: Service status report
JBAS014777: Services which failed to start: service jboss.deployment.unit."casadocodigo.war".FIRST_MODULE_USE

13:15:45,069 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) JBAS015003: Found casadocodigo.war in deployment directory. To trigger deployment create a file called casadocodigo.war.dodeploy
```

---

<div class="post-metadata">

**Author:** ![gracyane\_oliveira](https://avatars.discourse-cdn.com/v4/letter/g/f9ae1b/32.png) [@gracyane\_oliveira](https://forum.casadocodigo.com.br/u/gracyane_oliveira)\
**Post date:** [Março 16, 2017, 1:15am UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/4 "2017-03-16T01:15:00Z")

</div>

Pode estar faltando alguma coisa na parte de configuração do banco. Você tem esse código no github?

---

<div class="post-metadata">

**Author:** ![danilogp](https://avatars.discourse-cdn.com/v4/letter/d/f17d59/32.png) [@danilogp](https://forum.casadocodigo.com.br/u/danilogp)\
**Post date:** [Março 16, 2017, 1:53am UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/5 "2017-03-16T01:53:38Z")

</div>

Tenho sim Gracyane. [https://github.com/danilogp1/casadocodigo](https://github.com/danilogp1/casadocodigo)

---

<div class="post-metadata">

**Author:** ![gracyane\_oliveira](https://avatars.discourse-cdn.com/v4/letter/g/f9ae1b/32.png) [@gracyane\_oliveira](https://forum.casadocodigo.com.br/u/gracyane_oliveira)\
**Post date:** [Março 16, 2017, 3:14am UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/6 "2017-03-16T03:14:00Z")

</div>

Confira a parte da configuração no arquivo standalone-full.xml.

A minha configuração ficou assim:

 ![](https://canada1.discourse-cdn.com/flex029/uploads/casadocodigo/original/2X/0/08ecbc551ab1ad128c7d23248b6d1972e2d63cdb.png)

Outra coisa: você não precisa colocar new BookDAO() conforme abaixo, pois você já está usando o @Inject. Na classe: AdminBooksBean  
\> @Inject

> ```
> private BookDAO bookDAO = new BookDAO();
> 
> ```

---

<div class="post-metadata">

**Author:** ![gracyane\_oliveira](https://avatars.discourse-cdn.com/v4/letter/g/f9ae1b/32.png) [@gracyane\_oliveira](https://forum.casadocodigo.com.br/u/gracyane_oliveira)\
**Post date:** [Março 16, 2017, 3:17am UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/7 "2017-03-16T03:17:10Z")

</div>

Também verifique se o driver do mysql está no local adequado conforme autor explica.

---

<div class="post-metadata">

**Author:** ![danilogp](https://avatars.discourse-cdn.com/v4/letter/d/f17d59/32.png) [@danilogp](https://forum.casadocodigo.com.br/u/danilogp)\
**Post date:** [Março 16, 2017, 10:51pm UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/8 "2017-03-16T22:51:15Z")

</div>

Gracyane meus arquivos estão desta forma:

**Configuração do arquivo do MySQL**

 ![](https://canada1.discourse-cdn.com/flex029/uploads/casadocodigo/original/2X/8/8fabf1096c64e5a66887015e025f057c917a06a1.png)

**Configuração do Persistence.xml**

 ![](https://canada1.discourse-cdn.com/flex029/uploads/casadocodigo/original/2X/3/3f170c2b7b4a541738419655c2031d343a4264cc.png)

Configuração do arquivo standalone-full.xml

 ![](https://canada1.discourse-cdn.com/flex029/uploads/casadocodigo/original/2X/b/b791560992c2bb31ec9154ce3c1cf4ed84365fc9.png)

Eu fiz a correção da classe AdminBooksBean, mesmo assim ocorre o erro.

---

<div class="post-metadata">

**Author:** ![danilogp](https://avatars.discourse-cdn.com/v4/letter/d/f17d59/32.png) [@danilogp](https://forum.casadocodigo.com.br/u/danilogp)\
**Post date:** [Março 19, 2017, 10:02pm UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/9 "2017-03-19T22:02:58Z")

</div>

Coloquei o codigo do persistence.xml em apenas uma linha, aquele erro resolveu agora esta dando outro. ![](https://canada1.discourse-cdn.com/flex029/uploads/casadocodigo/original/2X/8/8bdb87a393edb68cabc2095476056d134583f6cb.png)

**Erro do log**

```
18:59:47,649 INFO [org.jboss.modules] (main) JBoss Modules version 1.3.3.Final
18:59:47,984 INFO [org.jboss.msc] (main) JBoss MSC version 1.2.2.Final
18:59:48,073 INFO [org.jboss.as] (MSC service thread 1-6) JBAS015899: WildFly 8.2.1.Final "Tweek" starting
18:59:50,497 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015014: Re-attempting failed deployment casadocodigo.war
18:59:50,509 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015003: Found casadocodigo.war in deployment directory. To trigger deployment create a file called casadocodigo.war.dodeploy
18:59:50,535 INFO [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http)
18:59:50,561 INFO [org.xnio] (MSC service thread 1-6) XNIO version 3.3.0.Final
18:59:50,575 INFO [org.xnio.nio] (MSC service thread 1-6) XNIO NIO Implementation Version 3.3.0.Final
18:59:50,672 INFO [org.jboss.as.security] (ServerService Thread Pool -- 51) JBAS013171: Activating Security Subsystem
18:59:50,683 WARN [org.jboss.as.txn] (ServerService Thread Pool -- 52) JBAS010153: Node identifier property is set to the default value. Please make sure it is unique.
18:59:50,694 INFO [org.jboss.as.webservices] (ServerService Thread Pool -- 54) JBAS015537: Activating WebServices Extension
18:59:50,722 INFO [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 30) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3)
18:59:50,763 INFO [org.jboss.as.jacorb] (ServerService Thread Pool -- 36) JBAS016300: Activating JacORB Subsystem
18:59:50,765 INFO [org.wildfly.extension.io] (ServerService Thread Pool -- 34) WFLYIO001: Worker 'default' has auto-configured to 8 core threads with 64 task threads based on your 4 available processors
18:59:50,782 INFO [org.jboss.as.security] (MSC service thread 1-8) JBAS013170: Current PicketBox version=4.0.21.Final
18:59:50,784 INFO [org.wildfly.extension.undertow] (ServerService Thread Pool -- 53) JBAS017502: Undertow 1.1.8.Final starting
18:59:50,785 INFO [org.jboss.as.naming] (ServerService Thread Pool -- 46) JBAS011800: Activating Naming Subsystem
18:59:50,790 INFO [org.wildfly.extension.undertow] (MSC service thread 1-4) JBAS017502: Undertow 1.1.8.Final starting
18:59:50,854 INFO [org.jboss.as.jsf] (ServerService Thread Pool -- 42) JBAS012615: Activated the following JSF Implementations: [main]
18:59:50,852 INFO [org.jboss.as.clustering.infinispan] (ServerService Thread Pool -- 35) JBAS010280: Activating Infinispan subsystem.
18:59:50,861 INFO [org.jboss.as.naming] (MSC service thread 1-7) JBAS011802: Starting Naming Service
18:59:50,886 INFO [org.jboss.as.mail.extension] (MSC service thread 1-8) JBAS015400: Bound mail session [java:jboss/mail/Default]
18:59:50,905 INFO [org.jboss.as.connector.logging] (MSC service thread 1-7) JBAS010408: Starting JCA Subsystem (IronJacamar 1.1.9.Final)
18:59:50,925 INFO [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-8) JBAS010417: Started Driver service with driver-name = h2
18:59:50,972 INFO [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 30) JBAS010404: Deploying non-JDBC-compliant driver class com.mysql.jdbc.Driver (version 5.1)
18:59:50,975 INFO [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-1) JBAS010417: Started Driver service with driver-name = mysql
18:59:51,579 INFO [org.wildfly.extension.undertow] (ServerService Thread Pool -- 53) JBAS017527: Creating file handler for path C:\Users\danil\wildfly-8.2.1.Final/welcome-content
18:59:51,915 INFO [org.wildfly.extension.undertow] (MSC service thread 1-4) JBAS017525: Started server default-server.
18:59:51,939 INFO [org.wildfly.extension.undertow] (MSC service thread 1-4) JBAS017531: Host default-host starting
18:59:51,939 INFO [org.jboss.remoting] (MSC service thread 1-6) JBoss Remoting version 4.0.7.Final
18:59:52,125 INFO [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "casadocodigo.war" (runtime-name: "casadocodigo.war")
18:59:52,150 INFO [org.jboss.as.server.deployment.scanner] (MSC service thread 1-3) JBAS015012: Started FileSystemDeploymentService for directory C:\Users\danil\wildfly-8.2.1.Final\standalone\deployments
18:59:52,201 INFO [org.wildfly.extension.undertow] (MSC service thread 1-2) JBAS017519: Undertow HTTP listener default listening on localhost/127.0.0.1:8080
18:59:52,272 WARN [org.jboss.as.messaging] (MSC service thread 1-4) JBAS011600: AIO wasn't located on this platform, it will fall back to using pure Java NIO. If your platform is Linux, install LibAIO to enable the AIO journal
18:59:52,542 WARN [jacorb.codeset] (MSC service thread 1-7) Warning - unknown codeset (Cp1252) - defaulting to ISO-8859-1
18:59:52,607 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221000: live server is starting with configuration HornetQ Configuration (clustered=false,backup=false,sharedStore=true,journalDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messagingjournal,bindingsDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messagingbindings,largeMessagesDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messaginglargemessages,pagingDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messagingpaging)
18:59:52,616 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221006: Waiting to obtain live lock
18:59:52,787 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221013: Using NIO Journal
18:59:52,804 INFO [org.jboss.as.jacorb] (MSC service thread 1-7) JBAS016330: CORBA ORB Service started
18:59:52,869 INFO [io.netty.util.internal.PlatformDependent] (ServerService Thread Pool -- 56) Your platform does not provide complete low-level API for accessing direct buffers reliably. Unless explicitly requested, heap buffer will always be preferred to avoid potential system unstability.
18:59:52,960 INFO [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-6) JBAS010400: Bound data source [java:jboss/datasources/casadocodigoDS]
18:59:52,961 INFO [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-5) JBAS010400: Bound data source [java:jboss/datasources/ExampleDS]
18:59:53,058 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221043: Adding protocol support CORE
18:59:53,100 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221043: Adding protocol support AMQP
18:59:53,219 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221043: Adding protocol support STOMP
18:59:53,391 INFO [org.jboss.as.jpa] (MSC service thread 1-1) JBAS011401: Read persistence.xml for casadocodigo-dev
18:59:53,404 INFO [org.jboss.as.jacorb] (MSC service thread 1-7) JBAS016328: CORBA Naming Service started
18:59:53,464 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221034: Waiting to obtain live lock
18:59:53,465 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221035: Live Server Obtained live lock
18:59:53,621 INFO [org.jboss.ws.common.management] (MSC service thread 1-2) JBWS022052: Starting JBoss Web Services - Stack CXF Server 4.3.2.Final
18:59:53,961 INFO [org.jboss.messaging] (MSC service thread 1-4) JBAS011615: Registered HTTP upgrade for hornetq-remoting protocol handled by http-acceptor acceptor
18:59:53,962 INFO [org.jboss.messaging] (MSC service thread 1-3) JBAS011615: Registered HTTP upgrade for hornetq-remoting protocol handled by http-acceptor-throughput acceptor
18:59:54,261 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221007: Server is now live
18:59:54,262 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221001: HornetQ Server version 2.4.5.FINAL (Wild Hornet, 124) [54408336-f7c9-11e6-abc8-3d133fa96cc9] 
18:59:54,404 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221003: trying to deploy queue jms.queue.DLQ
18:59:54,431 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 56) JBAS011601: Bound messaging object to jndi name java:/jms/queue/DLQ
18:59:54,560 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 58) JBAS011601: Bound messaging object to jndi name java:jboss/exported/jms/RemoteConnectionFactory
18:59:54,563 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 59) JBAS011601: Bound messaging object to jndi name java:/ConnectionFactory
18:59:54,567 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 57) HQ221003: trying to deploy queue jms.queue.ExpiryQueue
18:59:54,591 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 57) JBAS011601: Bound messaging object to jndi name java:/jms/queue/ExpiryQueue
18:59:54,657 INFO [org.jboss.as.connector.deployment] (MSC service thread 1-3) JBAS010406: Registered connection factory java:/JmsXA
18:59:55,129 INFO [org.hornetq.ra] (MSC service thread 1-3) HornetQ resource adaptor started
18:59:55,130 INFO [org.jboss.as.connector.services.resourceadapters.ResourceAdapterActivatorService$ResourceAdapterActivator] (MSC service thread 1-3) IJ020002: Deployed: file://RaActivatorhornetq-ra
18:59:55,135 INFO [org.jboss.as.connector.deployment] (MSC service thread 1-3) JBAS010401: Bound JCA ConnectionFactory [java:/JmsXA]
18:59:55,135 INFO [org.jboss.as.messaging] (MSC service thread 1-8) JBAS011601: Bound messaging object to jndi name java:jboss/DefaultJMSConnectionFactory
18:59:55,148 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) JBAS014613: Operation ("deploy") failed - address: ([("deployment" => "casadocodigo.war")]) - failure description: {"JBAS014771: Services with missing/unavailable dependencies" => ["jboss.persistenceunit.\"casadocodigo.war#casadocodigo-dev\". __FIRST_PHASE__ is missing [jboss.naming.context.java.jboss.java:jboos.datasources.casadocodigoDS]"]}
18:59:55,324 INFO [org.jboss.as.server] (ServerService Thread Pool -- 31) JBAS018559: Deployed "casadocodigo.war" (runtime-name : "casadocodigo.war")
18:59:55,337 INFO [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014775: New missing/unsatisfied dependencies:
      service jboss.naming.context.java.jboss.java:jboos.datasources.casadocodigoDS (missing) dependents: [service jboss.persistenceunit."casadocodigo.war#casadocodigo-dev". __FIRST_PHASE__] 

18:59:55,446 INFO [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management
18:59:55,446 INFO [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
18:59:55,447 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: WildFly 8.2.1.Final "Tweek" started (with errors) in 8241ms - Started 237 of 288 services (2 services failed or missing dependencies, 95 services are lazy, passive or on-demand)
18:59:55,619 INFO [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015877: Stopped deployment casadocodigo.war (runtime-name: casadocodigo.war) in 18ms
18:59:55,811 INFO [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018558: Undeployed "casadocodigo.war" (runtime-name: "casadocodigo.war")
18:59:55,813 INFO [org.jboss.as.controller] (DeploymentScanner-threads - 2) JBAS014774: Service status report
JBAS014775: New missing/unsatisfied dependencies:
      service jboss.persistenceunit."casadocodigo.war#casadocodigo-dev". __FIRST_PHASE__ (missing) dependents: [service jboss.deployment.unit."casadocodigo.war".POST_MODULE] 

19:00:00,374 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) JBAS015003: Found casadocodigo.war in deployment directory. To trigger deployment create a file called casadocodigo.war.dodeploy
```

---

<div class="post-metadata">

**Author:** ![gracyane\_oliveira](https://avatars.discourse-cdn.com/v4/letter/g/f9ae1b/32.png) [@gracyane\_oliveira](https://forum.casadocodigo.com.br/u/gracyane_oliveira)\
**Post date:** [Março 19, 2017, 10:27pm UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/10 "2017-03-19T22:27:00Z")

</div>

O erro menciona "New missing/unsatisfied dependencies"  
Faça um “Update Maven” no projeto. Atalho (Alt+F5 para Update Maven)

---

<div class="post-metadata">

**Author:** ![danilogp](https://avatars.discourse-cdn.com/v4/letter/d/f17d59/32.png) [@danilogp](https://forum.casadocodigo.com.br/u/danilogp)\
**Post date:** [Março 19, 2017, 11:13pm UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/11 "2017-03-19T23:13:10Z")

</div>

**Fiz a atualização, acho q continua com o mesmo erro**

```
   20:12:24,404 INFO [org.jboss.modules] (main) JBoss Modules version 1.3.3.Final
20:12:24,746 INFO [org.jboss.msc] (main) JBoss MSC version 1.2.2.Final
20:12:24,842 INFO [org.jboss.as] (MSC service thread 1-6) JBAS015899: WildFly 8.2.1.Final "Tweek" starting
20:12:27,178 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015003: Found casadocodigo.war in deployment directory. To trigger deployment create a file called casadocodigo.war.dodeploy
20:12:27,210 INFO [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http)
20:12:27,242 INFO [org.xnio] (MSC service thread 1-4) XNIO version 3.3.0.Final
20:12:27,263 INFO [org.xnio.nio] (MSC service thread 1-4) XNIO NIO Implementation Version 3.3.0.Final
20:12:27,377 INFO [org.jboss.as.clustering.infinispan] (ServerService Thread Pool -- 35) JBAS010280: Activating Infinispan subsystem.
20:12:27,404 INFO [org.wildfly.extension.io] (ServerService Thread Pool -- 34) WFLYIO001: Worker 'default' has auto-configured to 8 core threads with 64 task threads based on your 4 available processors
20:12:27,358 INFO [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 30) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3)
20:12:27,449 INFO [org.jboss.as.jacorb] (ServerService Thread Pool -- 36) JBAS016300: Activating JacORB Subsystem
20:12:27,469 INFO [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 30) JBAS010404: Deploying non-JDBC-compliant driver class com.mysql.jdbc.Driver (version 5.1)
20:12:27,501 WARN [org.jboss.as.txn] (ServerService Thread Pool -- 52) JBAS010153: Node identifier property is set to the default value. Please make sure it is unique.
20:12:27,514 INFO [org.jboss.as.security] (ServerService Thread Pool -- 51) JBAS013171: Activating Security Subsystem
20:12:27,521 INFO [org.jboss.as.jsf] (ServerService Thread Pool -- 42) JBAS012615: Activated the following JSF Implementations: [main]
20:12:27,557 INFO [org.jboss.as.naming] (ServerService Thread Pool -- 46) JBAS011800: Activating Naming Subsystem
20:12:27,567 INFO [org.jboss.as.security] (MSC service thread 1-7) JBAS013170: Current PicketBox version=4.0.21.Final
20:12:27,579 INFO [org.jboss.as.webservices] (ServerService Thread Pool -- 54) JBAS015537: Activating WebServices Extension
20:12:27,652 INFO [org.jboss.as.connector.logging] (MSC service thread 1-5) JBAS010408: Starting JCA Subsystem (IronJacamar 1.1.9.Final)
20:12:27,700 INFO [org.wildfly.extension.undertow] (MSC service thread 1-8) JBAS017502: Undertow 1.1.8.Final starting
20:12:27,726 INFO [org.wildfly.extension.undertow] (ServerService Thread Pool -- 53) JBAS017502: Undertow 1.1.8.Final starting
20:12:28,102 INFO [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-7) JBAS010417: Started Driver service with driver-name = h2
20:12:28,131 INFO [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-8) JBAS010417: Started Driver service with driver-name = mysql
20:12:28,310 INFO [org.jboss.as.naming] (MSC service thread 1-8) JBAS011802: Starting Naming Service
20:12:28,328 INFO [org.jboss.as.mail.extension] (MSC service thread 1-3) JBAS015400: Bound mail session [java:jboss/mail/Default]
20:12:28,784 INFO [org.jboss.remoting] (MSC service thread 1-1) JBoss Remoting version 4.0.7.Final
20:12:28,861 INFO [org.wildfly.extension.undertow] (ServerService Thread Pool -- 53) JBAS017527: Creating file handler for path C:\Users\danil\wildfly-8.2.1.Final/welcome-content
20:12:28,921 INFO [org.wildfly.extension.undertow] (MSC service thread 1-7) JBAS017525: Started server default-server.
20:12:28,942 INFO [org.wildfly.extension.undertow] (MSC service thread 1-7) JBAS017531: Host default-host starting
20:12:29,259 INFO [org.jboss.as.server.deployment.scanner] (MSC service thread 1-1) JBAS015012: Started FileSystemDeploymentService for directory C:\Users\danil\wildfly-8.2.1.Final\standalone\deployments
20:12:29,282 INFO [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015876: Starting deployment of "casadocodigo.war" (runtime-name: "casadocodigo.war")
20:12:29,365 INFO [org.wildfly.extension.undertow] (MSC service thread 1-3) JBAS017519: Undertow HTTP listener default listening on localhost/127.0.0.1:8080
20:12:29,697 WARN [jacorb.codeset] (MSC service thread 1-5) Warning - unknown codeset (Cp1252) - defaulting to ISO-8859-1
20:12:29,891 WARN [org.jboss.as.messaging] (MSC service thread 1-7) JBAS011600: AIO wasn't located on this platform, it will fall back to using pure Java NIO. If your platform is Linux, install LibAIO to enable the AIO journal
20:12:30,053 INFO [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-8) JBAS010400: Bound data source [java:jboss/datasources/casadocodigoDS]
20:12:30,055 INFO [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-4) JBAS010400: Bound data source [java:jboss/datasources/ExampleDS]
20:12:30,067 INFO [org.jboss.as.jacorb] (MSC service thread 1-5) JBAS016330: CORBA ORB Service started
20:12:30,243 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221000: live server is starting with configuration HornetQ Configuration (clustered=false,backup=false,sharedStore=true,journalDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messagingjournal,bindingsDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messagingbindings,largeMessagesDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messaginglargemessages,pagingDirectory=C:\Users\danil\wildfly-8.2.1.Final\standalone\data\messagingpaging)
20:12:30,300 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221006: Waiting to obtain live lock
20:12:30,456 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221013: Using NIO Journal
20:12:30,558 INFO [io.netty.util.internal.PlatformDependent] (ServerService Thread Pool -- 56) Your platform does not provide complete low-level API for accessing direct buffers reliably. Unless explicitly requested, heap buffer will always be preferred to avoid potential system unstability.
20:12:30,569 INFO [org.jboss.as.jacorb] (MSC service thread 1-4) JBAS016328: CORBA Naming Service started
20:12:30,635 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221043: Adding protocol support CORE
20:12:30,676 INFO [org.jboss.as.jpa] (MSC service thread 1-2) JBAS011401: Read persistence.xml for casadocodigo-dev
20:12:30,704 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221043: Adding protocol support AMQP
20:12:30,712 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221043: Adding protocol support STOMP
20:12:30,841 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221034: Waiting to obtain live lock
20:12:30,842 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221035: Live Server Obtained live lock
20:12:30,853 INFO [org.jboss.ws.common.management] (MSC service thread 1-3) JBWS022052: Starting JBoss Web Services - Stack CXF Server 4.3.2.Final
20:12:31,417 INFO [org.jboss.messaging] (MSC service thread 1-8) JBAS011615: Registered HTTP upgrade for hornetq-remoting protocol handled by http-acceptor acceptor
20:12:31,418 INFO [org.jboss.messaging] (MSC service thread 1-4) JBAS011615: Registered HTTP upgrade for hornetq-remoting protocol handled by http-acceptor-throughput acceptor
20:12:31,697 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221007: Server is now live
20:12:31,698 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 56) HQ221001: HornetQ Server version 2.4.5.FINAL (Wild Hornet, 124) [54408336-f7c9-11e6-abc8-3d133fa96cc9] 
20:12:31,866 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 56) JBAS011601: Bound messaging object to jndi name java:jboss/exported/jms/RemoteConnectionFactory
20:12:31,921 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 58) HQ221003: trying to deploy queue jms.queue.DLQ
20:12:31,967 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 58) JBAS011601: Bound messaging object to jndi name java:/jms/queue/DLQ
20:12:31,980 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 59) HQ221003: trying to deploy queue jms.queue.ExpiryQueue
20:12:31,981 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 59) JBAS011601: Bound messaging object to jndi name java:/jms/queue/ExpiryQueue
20:12:31,983 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 57) JBAS011601: Bound messaging object to jndi name java:/ConnectionFactory
20:12:32,059 INFO [org.jboss.as.connector.deployment] (MSC service thread 1-7) JBAS010406: Registered connection factory java:/JmsXA
20:12:32,211 INFO [org.hornetq.ra] (MSC service thread 1-7) HornetQ resource adaptor started
20:12:32,212 INFO [org.jboss.as.connector.services.resourceadapters.ResourceAdapterActivatorService$ResourceAdapterActivator] (MSC service thread 1-7) IJ020002: Deployed: file://RaActivatorhornetq-ra
20:12:32,217 INFO [org.jboss.as.connector.deployment] (MSC service thread 1-2) JBAS010401: Bound JCA ConnectionFactory [java:/JmsXA]
20:12:32,218 INFO [org.jboss.as.messaging] (MSC service thread 1-7) JBAS011601: Bound messaging object to jndi name java:jboss/DefaultJMSConnectionFactory
20:12:32,240 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) JBAS014613: Operation ("deploy") failed - address: ([("deployment" => "casadocodigo.war")]) - failure description: {"JBAS014771: Services with missing/unavailable dependencies" => ["jboss.persistenceunit.\"casadocodigo.war#casadocodigo-dev\". __FIRST_PHASE__ is missing [jboss.naming.context.java.jboss.java:jboos.datasources.casadocodigoDS]"]}
20:12:32,832 INFO [org.jboss.as.server] (ServerService Thread Pool -- 31) JBAS018559: Deployed "casadocodigo.war" (runtime-name : "casadocodigo.war")
20:12:32,844 INFO [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014775: New missing/unsatisfied dependencies:
      service jboss.naming.context.java.jboss.java:jboos.datasources.casadocodigoDS (missing) dependents: [service jboss.persistenceunit."casadocodigo.war#casadocodigo-dev". __FIRST_PHASE__] 

20:12:33,100 INFO [org.jboss.as.server.deployment] (MSC service thread 1-6) JBAS015877: Stopped deployment casadocodigo.war (runtime-name: casadocodigo.war) in 18ms
20:12:33,121 INFO [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management
20:12:33,122 INFO [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
20:12:33,123 INFO [org.jboss.as] (Controller Boot Thread) JBAS015874: WildFly 8.2.1.Final "Tweek" started in 9104ms - Started 224 of 273 services (93 services are lazy, passive or on-demand)
20:12:33,299 INFO [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018558: Undeployed "casadocodigo.war" (runtime-name: "casadocodigo.war")
20:12:33,300 INFO [org.jboss.as.controller] (DeploymentScanner-threads - 2) JBAS014774: Service status report
JBAS014775: New missing/unsatisfied dependencies:
      service jboss.persistenceunit."casadocodigo.war#casadocodigo-dev". __FIRST_PHASE__ (missing) dependents: [service jboss.deployment.unit."casadocodigo.war".POST_MODULE] 

20:12:37,909 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) JBAS015003: Found casadocodigo.war in deployment directory. To trigger deployment create a file called casadocodigo.war.dodeploy
```

---

<div class="post-metadata">

**Author:** ![gracyane\_oliveira](https://avatars.discourse-cdn.com/v4/letter/g/f9ae1b/32.png) [@gracyane\_oliveira](https://forum.casadocodigo.com.br/u/gracyane_oliveira)\
**Post date:** [Março 20, 2017, 12:13am UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/12 "2017-03-20T00:13:12Z")

</div>

O JBoss parece que tem uma forma própria de empacotar o projeto para deploy.  
No final do erro encontramos:

> JBAS014775: New missing/unsatisfied dependencies:  
> service jboss.persistenceunit.“casadocodigo.war#casadocodigo-dev”. **FIRST\_PHASE** (missing) dependents: [service jboss.deployment.unit.“casadocodigo.war”.POST\_MODULE]

> 20:12:37,909 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) JBAS015003: Found casadocodigo.war in deployment directory. To trigger deployment create a file called casadocodigo.war.dodeploy

Veja esta resposta no stackoverflow:

> <https://stackoverflow.com/questions/7366135/jboss-as7-dodeploy-files>

Eu não tive este problema, talvez seja a versão que você esteja usando.

---

<div class="post-metadata">

**Author:** ![danilogp](https://avatars.discourse-cdn.com/v4/letter/d/f17d59/32.png) [@danilogp](https://forum.casadocodigo.com.br/u/danilogp)\
**Post date:** [Março 20, 2017, 11:01pm UTC](https://forum.casadocodigo.com.br/t/erro-o-rodar-aplicacao-java-ee/465/13 "2017-03-20T23:01:37Z")

</div>

A versão do wildFly que estou utilizando é a mesma do livro, versão 8.
