Flutter - Exception

Estou lendo o livro Iniciando com Flutter Framework e me deparei com a seguinte exceção no capítulo Dependências:
MissingPluginException(No implementation found for method readQRCode on channel qrcode_reader)
Acredito que ela é lançada pelo plugin QRCode Reader, mas não consigo corrigir o problema, mesmo alterando sua versão.

Olá bbrneto, quando eu fiz o import ficou marcado como erro, então percebi que mesmo a IDE informando que fez o download parece que não baixou. No livro diz o seguinte:

Quando salvar a alteração no arquivo a sua IDE ou editor de texto vai atualizar e baixar as novas dependências (ou pelo menos deveria). Caso não baixe de forma automática, utilize no
terminal/shell/bash o seguinte comando: flutter packages get . É necessário que o terminal esteja no diretório da pasta do projeto qr_code .

Fiz isso e resolveu.

O link para o plugin é esse: https://pub.dev/packages/qrcode_reader/install
E a dependência a ser adicionada é essa: qrcode_reader: ^0.4.4

OBS 1: O import eu fiz igual como está no livro:
import ‘package:qrcode_reader/qrcode_reader.dart’;

Fazendo o import como está no Readme do plugin (import ‘package:qrcode_reader/QRCodeReader.dart’) estava apresentando erro.

OBS 2: O nome do seu projeto não pode ser o mesmo da dependência.
https://stackoverflow.com/questions/55297594/flutter-google-places-0-2-1-plugin-error-in-pubspec-yaml-file

Olá bbrneto, eu também tive problemas com esse exemplo do livro.
Rodando o projeto que está no GitHub do autor funcinou.

Obrigado, @gazal! Problema resolvido.