Versão anterior: AngularJS

angular

#1

Comprei o livro sobre Angular 2 ontem (18.02.2018) e quero acompanhar os exemplos passo a passo. No entanto, no meu computador já tenho uma versão (antiga) do AngularJS (1.0) e desejo desinstalar essa versão para, depois, instalar a versão que está sendo usada pelo livro. Assim, pergunto:
Como desinstalar a versão do AngularJS pelo npm? Tentei o npm desinstall mas não funcionou…
Grato


#2

Olá,

Você só precisa verificar a versão do Node.js e instalar o Angular.

O Node.js precisa ser maior que 6.9, para verificar a versão do seu Node.js, execute o comando node -v no seu terminal.

Para instalar o Angular, somente precisa executar o comando npm install -g @angular/cli no seu terminal.

Qualquer dúvida, estamos a disposição.


#3

Bom dia, Thiago.
Instalei a versão 4 do Angular. Posso desenvolver os exemplos do livro com
essa versão?

Caso não seja possível utilizar a versão, como deverei proceder para
instalar a versão usada pelo livro? Tenho que desinstalar
a versão 4? Como devo fazer para desinstalar a versão 4?
Grato pela atenção.


#4

Olá,

Pode desenvolver tranquilamente, o Angular a partir da versão 2, ou seja, Angular 2+ (versões, 2, 4, 5, outros), são todos compatíveis.

Você irá conseguir fazer o livro tranquilamente, caso tenha alguma dúvida, fico a disposição!

Desde já, bons estudos!